شکل گرفتن هاست خود و اینکه چرا باید نسخه های پشتیبانی نشده PHP را به روز کنید • Yoast

شکل گرفتن هاست خود و اینکه چرا باید نسخه های پشتیبانی نشده PHP را به روز کنید • Yoast

در این پست، می‌خواهیم به اهمیت ارتقاء PHP خود بپردازیم، اگر از نسخه قدیمی‌تر و پشتیبانی‌نشده استفاده می‌کنید. وقتی صحبت از امنیت و سرعت وب سایت شما به میان می آید، این امر بسیار مهم است. بنابراین هنوز کلیک نکنید، زیرا ما یک به روز رسانی مهم در مورد Yoast SEO، Yoast SEO Premium، و افزونه ها و پلاگین های مستقل خود مانند Yoast Duplicate Post داریم. تا 1 نوامبر 2024، دیگر از نسخه های 7.2 و 7.3 PHP پشتیبانی نخواهیم کرد. این تغییر بسیار مهم است زیرا ما به طور مداوم در تلاش برای بهبود امنیت و کارایی افزونه های خود هستیم. بخوانید تا بفهمید چرا.

پی اچ پی؟ میزبانی؟ همه ی اینها چه معنایی میدهد؟

وردپرس (مانند SEO Yoast) تا حد زیادی در یک زبان برنامه نویسی به نام PHP ساخته شده است. این زبان به عنوان خود وردپرس به مرور زمان پیشرفت کرده است. توسعه دهندگان وب در سراسر جهان از ویژگی هایی که نسخه های جدیدتر PHP به ارمغان آورده اند، لذت می برند. همچنین، مهمتر از همه، همه در سراسر جهان از افزایش امنیت این نسخه های جدید لذت می برند. متأسفانه، توسعه دهندگان وردپرس نمی توانند به آن بپیوندند.

در حال حاضر حداقل PHP مورد نیاز برای وردپرس PHP نسخه 7.0 است. اما آنها استفاده از PHP نسخه 7.4 یا بالاتر را توصیه می کنند. در مقایسه با وردپرس، PHP مسیر به روز رسانی نسبتاً تهاجمی دارد. PHP 8.1 تا یک سال و نیم دیگر پشتیبانی امنیتی دریافت می کند، اما هر چیزی قدیمی تر از آن پشتیبانی نمی کند. همانطور که آنها در وب سایت خود ذکر می کنند، هر نسخه قدیمی تر از آن باید در اسرع وقت به روز شود زیرا ممکن است در معرض آسیب پذیری های امنیتی اصلاح نشده قرار گیرند.

چرا ما به این موضوع اهمیت می دهیم؟

در Yoast ما به چیزهای زیادی اهمیت می دهیم، اما دو چیز به طور خاص در این زمینه مهم است: خوشحالی کاربر و خوشحالی توسعه دهندگان. یک کاربر زمانی خوشحال می شود که یک سیستم مدیریت محتوای سریع، آسان برای نصب و ایمن مانند وردپرس برای ایجاد یک سایت داشته باشد. یک توسعه دهنده زمانی خوشحال می شود که بتواند از یک زبان و ابزار مدرن برای ساختن نرم افزار استفاده کند.

امنیت

مهم‌ترین دلیلی که ما می‌خواهیم حداقل نیاز را افزایش دهیم، امنیت است: نسخه‌های قدیمی‌تر PHP، در حالی که هنوز به طور فعال در میلیون‌ها سایت استفاده می‌شوند، دیگر به‌روزرسانی‌های امنیتی دریافت نمی‌کنند.

این نگرانی امنیتی یک نگرانی تئوریک نیست. بارها و بارها شاهد بوده ایم که دلیل شماره یک هک شدن سایت ها، نرم افزارهای قدیمی است. وردپرس دقیقاً به همین دلیل به‌روزرسانی‌های خودکار را برای به‌روزرسانی‌های امنیتی داخلی دارد. چرا مردم را وادار می کنیم تا وردپرس و افزونه های آن را به طور مرتب به روز کنند، اما اجازه دهیم نسخه PHP عقب بماند؟

سرعت

مشکل بزرگ دیگر سرعت است. گاهی اوقات گفته می شود که وردپرس کند است، اما اصلا لازم نیست کند باشد. اگر روی نسخه‌های قدیمی PHP اجرا می‌شود، مطمئناً کند است. این باعث از دست دادن بازدیدکنندگان سایت شما می شود و همچنین عامل مهمی در سئوی شما است، پس حتما این موضوع را جدی بگیرید.

زبان برنامه نویسی مدرن

PHP 7.3 که در سال 2018 منتشر شد، دیگر یک زبان مدرن نیست. این امر توسعه دهندگان را ناراضی می کند زیرا بسیاری از ویژگی های عالی را که بسیاری از زبان های برنامه نویسی اخیر دارند از دست می دهند.

این می تواند باعث شود که توسعه دهندگان بیشتری به وردپرس پشت کنند زیرا بسیار کند است. توسعه تم ها یا افزونه ها برای وردپرس، که در آن نسخه قدیمی PHP مورد نیاز است، یک دردسر است و بنابراین چندان سرگرم کننده نیست. با گذشت زمان، از دست دادن توسعه‌دهندگان می‌تواند به معنای از دست دادن مشارکت‌های بزرگ و سایر محصولات سریع‌تر باشد، و وردپرس سهم بازار را از دست خواهد داد.

افزایش عملکرد و امنیت

Yoast SEO با پشتیبانی فقط از PHP 7.4 و بالاتر می تواند شیوه های کدنویسی مدرن تری را پیاده سازی کند که عملکرد وب سایت شما را به میزان قابل توجهی بهبود می بخشد. کد سریعتر و کارآمدتر نه تنها سئو را افزایش می دهد، بلکه به تجربه کاربری بهتر و کاهش بار سرور کمک می کند و در نتیجه انرژی را کاهش می دهد.

این به‌روزرسانی همچنین زمینه را برای پیشرفت‌های آینده، از جمله آمادگی ما برای نسخه‌های PHP آینده، فراهم می‌کند. جلوتر ماندن از منحنی های فناوری تضمین می کند که ما همیشه می توانیم به روزترین ویژگی ها را بدون به خطر انداختن ثبات ارائه دهیم.

Yoast قرار است چه کاری انجام دهد؟

همانطور که گفتیم حداقل PHP مورد نیاز برای وردپرس PHP نسخه 7.0 است و توصیه می کنند از 7.4 یا بالاتر استفاده کنید. Yoast پشتیبانی از نسخه های 7.2 و 7.3 PHP را از نوامبر 2024 قطع خواهد کرد. تعهد ما به ارائه بهترین خدمات ممکن به شما به این معنی است که نرم افزار ما از پیشرفته ترین و ایمن ترین فناوری موجود استفاده می کند. حذف تدریجی نسخه‌های قدیمی‌تر PHP، بسیار شبیه به‌روزرسانی‌های قبلی ما، به ما این امکان را می‌دهد تا از ویژگی‌های جدیدتری استفاده کنیم که عملکرد افزونه و امنیت سایت را افزایش می‌دهد.

طبق آمار رسمی وردپرس، حدود 8 درصد از نصب های وردپرس هنوز بر روی PHP 7.2 و 7.3 کار می کنند. داده های ما درصد کمتری را در بین پایگاه کاربران ما نشان می دهد. ما معتقدیم که این انتقال تنها بر تعداد حداقلی از کاربران تأثیر خواهد گذاشت، اما برای حفظ استانداردهای بالای کیفیت و امنیت حیاتی است.

در حال به روز رسانی نسخه پی اچ پی

اگر در مورد نحوه ارتقاء نسخه PHP خود مطمئن نیستید، نگران نباشید – ما شما را تحت پوشش قرار داده ایم. از راهنمای جامع ما در مورد نحوه به روز رسانی PHP خود با منابعی برای خدمات میزبانی متعدد بازدید کنید. اگر هاست شما در لیست نیست، یک ایمیل الگویی برای شما ارسال می کنیم تا به ارائه دهنده هاست خود بفرستید و درخواست به روز رسانی کنید.

با تشکر فراوان از همه کسانی که قبلاً نسخه های PHP خود را در انتظار این تغییر ارتقا داده اند. ما خوشحالیم که با شما به سمت یک محیط وب امن تر، کارآمدتر و قوی تر سفر کنیم. منتظر به‌روزرسانی‌های بیشتر باشید زیرا ما به بهبود SEO SEO برای ارائه خدمات بهتر به شما ادامه می‌دهیم.

منبع: https://yoast.com/getting-your-hosting-into-shape/